[gmx-developers] Re: multicomponent lambda free energy calculations.
mrshirts at gmail.com
Thu Mar 18 03:50:30 CET 2010
> This sounds really useful, and I personally think something like this should be included in the main distribution: it is the natural generalization of the current code to something more usable.
Talking with Erik and Berk, this is something that will go in, and is
targeted for right after 4.5 (since feature inclusion is essentially
over for 4.1).
> Does this mean that the couple-lambda0 and couple-lambda1 keywords are essentially obsolete?
In theory, they are unneeded, but I have currently coded it up to
support all of the old keywords (except foreign-lambdas). Further
decisions can be made later.
> I have two suggestions:
> 1) there should probably be a pull code lambda
Right now, I'm feeding the restraint-lambdas into the pull code, since
that is essentially a restraint. I don't know that restraints and pull
code should both be on at the same time!
> 2) A small suggestion: the naming of these mdp variables is slightly confusing. I'd suggest naming the lambda sets 'lambdas': that way the idea that this is a set is reinforced. Also, the main setting (fep-lambda) can be named 'lambdas'. The lambda point identifier 'init_fep_state' should probably be something like 'init_lambda_state'.
These all sound like great ideas. I will implement this before any merging.
More information about the gmx-developers